发新话题
打印

MOPA p3 release 2009.4.18

MOPA p3 release 2009.4.18

如题,MOPA由m0n0wall和panabit整合而成,其版权由原著作人所有,此整合仅供大家测试学习,由此带来一切问题均不负责.如有侵权请通知,即刻删除.

简述
mopa(当前版本号p3)由m0n0wall 1.3b15+panabit0903正式版+0320特征库整合,采用ramdisk运行方式保持高稳定性,pa密码修改和特征库升级均无问题,由于mopa中pa程序经修改才可正常运行,故不支持程序升级(预计p4会加入支持pa所有升级).



安装: 安装方式同原版m0n0wall,用physdiskwrite写入或其他

使用:
1. m0n0wall同原版,仅加入shellcmd(未整合至菜单)
2. panabit初始化及启动控制由m0n0wall的系统高级配置页面设置,其web控制为避免冲突,改为https://ip:880
具体使用请参照相关资料,恕不提供技术支持
下载地址1:ftp://test@laokun.3322.org/embedded-1.3b15+panabit0903.0320_p3.img
下载地址2:http://ftp.m0n0china.org/deadmans/embedded-1.3b15+panabit0903.0320_p3.img


注意事项:
1.有一点需要注意,由于保存pa的配置我是直接hook了pa的提示操作成功函数来完成,但是pa的web不完全规范,导致的问题就是配置在部分地方不能即时保存,所以,如遇到此例问题,请在修改完成后,随意点个窗口的确定,以让提示操作完成从而保存好pa配置.
2. 在mono web系统高级配置页面初始化pa 网卡时请注意,输入格式必须为"lnc0 lnc1"
3. 在web初始化pa网卡后,将自动重启pa以适应新的修改,m0n0wall的pa部分和panabit的网卡初始化部分都会如此,请注意

Change log:

p3,仅修复p2中panabit启动环境问题,并升级程序和特征库为最新

Bug fix log:

p3
修复p2中不能启动panabit的问题

p2
暂无发现


p1
1.似乎启动日志有提示dnsmasq不能修改/etc/resolv.conf和/etc/hosts,此问题比较奇特,待修正,不过除dns转发,不影响使用(p2中已解决此bug)
2. m0n0wall 高级设置页面pa网卡配置问题(在p2中已解决)
老邪的马甲,恩
——————
X-wall正式发布
http://www.freexwall.com
群112337621

TOP

先顶一下再说。

TOP

邪,也不贴地址?
http://analyst.3322.org
搜索是最好的老师,请善用搜索。
请注意提问的技巧,把问题说清楚。

TOP

to 老A
我传不了,小猫传的
很不习惯发帖的说,麻烦
老邪的马甲,恩
——————
X-wall正式发布
http://www.freexwall.com
群112337621

TOP

以后要多发言啊,呵呵。
http://analyst.3322.org
搜索是最好的老师,请善用搜索。
请注意提问的技巧,把问题说清楚。

TOP

引用:
原帖由 analyst 于 2009-3-5 05:11 PM 发表
以后要多发言啊,呵呵。

省去某人ggyy的说,不过发言也得有环境吧,哈哈
老邪的马甲,恩
——————
X-wall正式发布
http://www.freexwall.com
群112337621

TOP

偷懒成功,支持老邪
收费承接ROS路由远程可配置的各种设置
大猫猫和兔子的家
出售美国VPN,虚拟主机,要的PM。

TOP

出了点问题

我在MONO里能看到4块网卡,rl0,rl1,rl2,rl3,配置好MONO,在高级设置里指定RL2,RL3给panabit,中间用空格隔开,进入panabit后提示找不到RL3,网络配置里接口名称下面空白。从新到MONO里只指定RL2,进panabit后在接口名称下能看到RL2,重起系统,重新指定为RL2空格RL3,再进panabit,仍然报错说RL3没有找到。

TOP

我在VM里设置也是这样的.我以为是VM的问题,看来真机也有这样的问题啊.MONO指定一块网块给PANA就不会出错.指定二块就说有块找不到

TOP

但是装以前熊版的那个版本就可以,不知道是我的硬件问题还是系统BUG,楼主麻烦来鉴定一下

TOP

发新话题